Connectivity issues for .io and other TLDs
Incident Report for Flying Circus
Resolved
It appears that the .IO registry has fixed the name server issues. It appears that some of the root nameservers delivered (cachable) NXDOMAIN answers thus convincing some clients that .IO domains do not exist.

We haven't seen an issue in our monitoring about this for the last hours and have seen reports on the internet from others that things went back to normal.
Posted about 1 month ago. Sep 20, 2017 - 20:41 CEST
Monitoring
We're seeing DNS resolution errors for .io domains (including our www.flyingcircus.io and my.flyingcircus.io) that appear to be caused by an issue in the global DNS infrastructure. Pingdom has also acknowledged that a large number of customers are reporting suspicious DNS resolution errors. Our DNS servers are working fine and your services are not affected by this directly. Resolution of our domains within our data centers is not affected. Recursive resolution for third party domains is likely to be affected by this as well.
Posted about 1 month ago. Sep 20, 2017 - 16:31 CEST