Major storage software upgrade (Ceph)
Scheduled for Feb 2, 08:00 CET  -  Feb 3, 20:00 CET
Update
We are postponing our storage upgrade due to a last minute issue. We noticed intermittent severe performance limitations with application impact on our development and staging clusters and were not able to solve them.

This issue has the potential to cause major performance degradation or repeated intermittent loss of availability for customer applications and we decided to take the time to solve this issue before attempting to update.

Our predicted new window for the Ceph upgrade will be February 2nd/3rd and we'll keep you updated until then.
Posted 10 days ago. Jan 11, 2019 - 17:42 CET
Scheduled
We have prepared a major version upgrade for our storage cluster software (Ceph).

Our preparation shows that we'll be able to roll out the update without downtime but may incur periods with reduced IO performance. We will also need to perform a data center wide live migration of all VMs to activate the new client software in our hypervisors.

The update has been tested, fixed all issues we found and evaluated it for multiple months. We have also performed multiple upgrades already ensuring suitability for production and reliability of our processes. Still, such a major update may incur issues in a production environment that may have not manifested before. We will be available all the time and monitor the systems closely to respond to any adverse affects as quickly as possible.
Posted about 1 month ago. Dec 17, 2018 - 09:58 CET
This scheduled maintenance affects: VM storage cluster.