DNS resolution issues for flyingcircus.io

Incident Report for Flying Circus

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 10:59 CEST

Monitoring

During deployment of DNSSEC a wrong key announced. This prevented further DNS resolution. The deployment was reverted. Resolution will be degraded until DNS caches have been expired.
Posted Sep 18, 2026 - 10:30 CEST

Investigating

We are seeing DNS resolution errors for flyingcircus.io (and only this domain). Customer domains and services are not affected.
Posted Sep 18, 2026 - 10:27 CEST
This incident affected: Central services, my.flyingcircus.io, and gitlab.flyingcircus.io.