Mailservers rejecting all incoming mails due to filter list shutdown

Incident Report for Flying Circus

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 13:23 CET

Monitoring

All affected hosts have received the hotfix. We're monitoring the situation.
Posted Mar 07, 2025 - 12:43 CET

Update

The hotfixes have been prepared for the 24.05 and 24.11 releases. Now the affected machines are switched over to resolve the issue.

Note that this hotfix is a pre-release of the upcoming 2025_006 release and hence contains multiple other changes ahead of schedule.
Posted Mar 07, 2025 - 11:30 CET

Identified

Currently all mailservers running on the Flying Circus NixOS platforms reject all incoming mails, as the filter list ix.dnsbl.manitu.net has ceased operations.

We are in the process of preparing a hotfix for the NixOS 24.05 and 24.11 platform versions, which will then be rolled out to all affected mailservers.
Posted Mar 07, 2025 - 09:49 CET
This incident affected: Central services.