We are seeing things improving globally. DENIC has not updated their status page yet, but external monitoring services are showing significant improvements and we haven't seen alerts for a while.
We'll keep this open until tomorrow morning to check back on the status and turn DNSSEC back on if everything looks back to normal on the DENIC side.
Posted May 06, 2026 - 00:41 CEST
Monitoring
Disabling DNSSEC for the time being appears to be providing relief. We've applied this to the main data center routers/resolvers and are also rolling this out in our other locations.
As this is only a workaround and there might be further impact not visible yet, we're keeping the statuspage on "partial outage" for now.
Posted May 05, 2026 - 22:44 CEST
Update
DENIC has confirmed having issues: https://status.denic.de (might not be accessible at the moment as it's ... hosted within the affected .de domain). It appears that there's a DNSSEC issue ongoing.
We're trying to see whether we can provide some relief by disabling DNSSEC checks intermediately.
Posted May 05, 2026 - 22:40 CEST
Identified
Global monitoring utilities [1] and [2] report major issues with the DE top level domain. We have not yet seen public comment from DENIC and are verifying whether other domains are impacted as well.
We're currently investigating widespread DNS issues with effects on resolution of DNS records from our platform, our customer DNS and external DNS zones.
We have found indicators of a potential widespread external issue but are following up on multiple leads at the moment.
Posted May 05, 2026 - 22:24 CEST
This incident affected: Central services, RZOB (production) (Network and Internet uplink), and RZHAL (backup and development data center) (Network and Internet uplink).