We have not become aware of any follow-up issues and consequences of this release mixup and consider this to be resolved.
Posted Jul 12, 2024 - 17:02 CEST
Monitoring
No production machines have been affected by the issue, all incorrect upgrade maintenances have been deleted or adjusted to the correct channel.
A subset of non-production machines has been updated to 24.05 and rolled back to 23.11 now, the onyl machines affected are the special case of non-production VMs that have the `fc-23.11-production` environment set. The recommended default environment for such machines is `fc-23.11-staging` though.
We are now monitoring whether there is unexpected consequences from these changes for the next few hours.
Posted Jul 12, 2024 - 14:10 CEST
Investigating
Due to an operator error, we prepared and announced system upgrades to 24.05 for all 23.11-production machines yesterday after 21:00 CEST. These upgrades are most likely not effective, yet. Maintenance activities are scheduled for a later time, typically on the next day, depending on the lead time configured for the project.
We have already rolled out a fix around 9:00 CEST today to revert the change.
We are investigating if some machines already ran the upgrade and will inform affected customers about the next steps. The new version 24.05 which was rolled out is generally safe and ready for production use, so we don't expect major problems.