gitlab registry not available

Incident Report for Flying Circus

Resolved

We updated a dependency of gitlab-container-registry and found a configuration error that we now have fixed. Our GitLab registry is available again. Customer GitLab instances were not affected at any time.
Posted Dec 09, 2025 - 09:07 CET

Identified

The gitlab registry is not available due to an error in gitlab itself. We are working with NixOS upstream to get fix as soon as possible.
Posted Dec 09, 2025 - 07:42 CET
This incident affected: gitlab.flyingcircus.io.