Replacing SSH RSA keys for github.com in known_hosts
Incident Report for Flying Circus
Resolved
We have replaced the key with the new one on all VMs that are currently online.
Posted Mar 24, 2023 - 14:58 CET
Investigating
GitHub announced that they had to replace their RSA SSH key for Git operations because their old private key was briefly exposed in public. Git via SSH operations may fail at the moment if the old public RSA key is saved in the user's known_hosts file.

We are currently checking all customer VMs for occurrences of the affected key in known_hosts files of human and service users, like /home/example/.ssh/known_hosts or /srv/s-serviceuser/.ssh/known_hosts, for example, and plan to replace the old key with the new key.

Please replace the affected key in other places you control, like developer machines and deployments. You can follow the instructions provided by github.com. See their post for details here: https://github.blog/2023-03-23-we-updated-our-rsa-ssh-host-key
Posted Mar 24, 2023 - 14:27 CET
This incident affected: Central services.